FANDOM


A normal map is an image created from an object's texture or original geometry mesh, giving the illusion of complex detail on simple objects. Normal maps are used to fake the lighting of bumps and dents on an object.

NVIDIA Photoshop PluginEdit

NVIDIA offers a free plugin Texture Tools for Photoshop on their developer site which includes Normal Mapping Filters.

Creating a Vehicle Normal Map (Photoshop)Edit

Before you can create a normal map in Photoshop, you must start with an image to base the normal calculations from. Usually, the object's color map may be used. You may also create a normal map from a blank canvas. Note: Your base image may require some modification to be suitable for an accurate normal map conversion


ProcessEdit

  1. Start with your base grayscale texture
    1. ensure you are working with a flattened document, you should only have one layer
    2. set your document color mode to rgb (Image > Mode > RGB Color)
  2. Navigate to Filter > NVIDIA Tools > NormalMapFilter
    1. for NVIDIA Texture Tools download link, see above
  3. Recommended Settings (use your own settings if needed):
    1. Height Generation: 5x5 sample
    2. Invert Y: checked on
    3. Height Source: Average RGB
    4. Alpha Field: Set to 1.0
  4. Click "OK" to apply settings. You are left with a standard normal map.
  5. Open your Channels (Window > Channels) and you should see four: RGB, Red, Green, Blue
  6. Switch to the Red Channel by clicking the "Red" layer. This should be the only layer active.
  7. Select all on your composition (Select > All or Ctrl/Cmd + A)
    1. you should see a moving dashed line around the border of your canvas
  8. Copy your entire layer (Edit > Copy or Ctrl/Cmd + C)
  9. Click the "Create new channel" button at the bottom of your channels window
    1. you should see a new channel called "Alpha 1" and it should be the only channel selected
  10. Paste your copied layer (Edit > Paste or Ctrl/Cmd + V)
  11. Deselect your selection (Select > Deselect or Ctrl/Cmd + D)
  12. Now switch to the Green Channel by clicking the "Green" layer. This should be the only layer active.
  13. Select all on your composition (Select > All or Ctrl/Cmd + A)
    1. you should see a moving dashed line around the border of your canvas
  14. Copy your entire layer (Edit > Copy or Ctrl/Cmd + C)
  15. Switch to the Red Channel by clicking the "Red" layer. This should be the only layer active.
  16. Paste your copied layer (Edit > Paste or Ctrl/Cmd + V)
  17. And switch to the Blue Channel by clicking the "Blue" layer. This should be the only layer active.
  18. Paste your copied layer (Edit > Paste or Ctrl/Cmd + V)
  19. Switch back to your RGB channels by clicking the top RGB channel


ConclusionEdit

You should have duplicated your Red channel to a new Alpha channel, followed by duplicating your Green channel to all three RGB channels. Once you're finished, you can save this image as a .DDS file, ready for importing into SimCityPak.

Special thanks to Tobse for contributions to this method

Ad blocker interference detected!


Wikia is a free-to-use site that makes money from advertising. We have a modified experience for viewers using ad blockers

Wikia is not accessible if you’ve made further modifications. Remove the custom ad blocker rule(s) and the page will load as expected.